Viagra online
www.flickr.com

Upgrade a Kubuntu 9.04: un incubo! (parte 1)

maggio 9, 2009 3:20 pm

Sicuramente avrete letto in un sacco di blog l’uscita il primo di maggio della nuova versione di Ubuntu, la 9.04.

Lo stesso giorno Canonical ha anche aggiornato le varianti di Ubuntu, compresa la Kubuntu, che rimpiazza GNOME con KDE. Come chi mi legge da qualche tempo sicuramente ricorda, io sono un felice utilizzatore di Kubuntu sia sul laptop che sul desktop dell’ufficio, entrambi DELL.

Dopo aver letto alcune “entusiasmanti” recensioni della versione 9.04 ho deciso di fare l’aggiornamento di entrambi i sistemi: in particolare tutti sembrano concordi sulle migliori performance (a parita` di hardware) sia nell’uso degli hard disk (grazie anche all’introduzione di ext4 come nuovo formato per il file system)  che nell’uso della scheda video (grazie alla nuova versione dell’Xserver).

Mi sono quindi scaricato via BitTorrent l’alternate CD: ovviamente avrei potuto fare l’aggiornamento direttamente online, ma visto che dovevo aggiornare due sistemi piu` sicuramente qualche altra macchina in ufficio, l’alternate CD era la strada migliore.

Vi raccontero` brevemente le mie esperienze, cercando di farvi “rivivere” l’incubo che ho vissuto e che sto ancora vivendo.

Aggiornamento del laptop

Il primo aggiornamento l’ho fatto sul laptop: a livello hardware e` la macchina che ha piu` problemi, specialmente per la scheda WiFi; tra l’altro e` l’unica macchina in cui ho un dual boot con Windows XP configurato e funzionante quindi il rischio dell’aggiornamento era minimo.

Il primo problema e` sorto durante il processo di configurazione dei nuovi pacchetti dall’alternative CD (che avevo montato direttamente da una chiave USB invece che masterizzarlo). Dopo aver trovato dei conflitti in alcuni file di configurazione mi e` stata data la possibilita` di scegliere cosa fare: tenere la mia versione, prendere la versione nuova perdendo le mie modifiche, provare a fare un “merge” automatico delle differenze. Piu` per curiosita` che per altro ho provato a scegliere questa terza opzione.. nonostante il messaggio era abbastanza chiaro (questa funzionalita` e` in beta e potrebbe non funzionare) non mi sarei mai aspettato che non solo generasse un errore ma interrompese tutto il processo di aggiornamento! Per fortuna rilanciandolo da capo ha ripreso da dove aveva lasciato, permettendomi comunque di ritrovarmi alla fine con una 9.04 completamente aggiornata.

Tutto sembrava andare per il meglio, se non che al primo riavvio la scheda WiFi si rifiuta di collegarsi alla mia rete: per dirla tutta la scheda e` abilitata (la lucina del WiFi sul laptop si accende) ma uno scanning delle reti disponibili non rileva nessuna rete. Penso ad un problema del network manager (KNetworkManager): avevo letto nelle release notes che con la nuova versione e` stato aggiunto un “plasma” (un componente “attivo” da piazzare sul desktop di KDE) per il network manager, ma questo non viene avviato automaticamente dopo un aggiornamento.

Purtroppo anche passando a linea di comando e cercando di abilitare il WiFi a mano i risultati sono stati gli stessi, nessuna rete trovata. Dopo un attimo di sconforto ho fatto un boot in Windows XP per provare a cercare qualche informazione su internet: niente che andasse veramente bene, solo un messaggio su un forum che consigliava di installare wicd per configurare la rete. Sicuramente non era il mio problema visto che a linea di comando le cose non funzionavano.

Rifatto un boot sotto Kubuntu, dopo una decina di prove di scanning a linea di comando, mi e` venuto il forte dubbio che fosse un problema di diritti.. ho provato quindi ha fare lo scanning da superuser e.. voila` la lista delle reti finalmente disponibile! Ho provato allora a lanciare il KNetworkManager da super user: sorpresa, mi chiede di accedere al KWallet! Il KWallet e` un sistema di garanzia della sicurezza di KDE. In pratica e` un raccoglitore di informazioni di sicurezza (username password) che altre applicazioni possono usare solo se autorizzate dal superuser. Apparte il fatto che io avevo gia` autorizzato KNetworkManager ad accedere al KWallet, la cosa strana e` che dopo l’aggiornamento alla 9.04 il sistema non mi aveva piu` chesto la main password del KWallet: questa operazione viene fatta generalmente all’avvio di KDE per aprire il KWallet per la prima volta (in realta` sarebbe piu` corretto dire che viene fatta la prima volta che un’applicazione chiede di accedere alle informazioni contenute).

Problema identificato quindi, per qualche strano motivo facendo l’aggiornamento il KNetworkManager ha perso l’associazione con il KWallet. Ma non solo, lo stesso user (unico nel sistema) sembra aver perso il diritto di fare scanning sulla carta WiFi.

Ero gia` pronto a iniziare a riconfigurare i diritti quando ho rifatto l’ennesimo reboot, e miracolo dei miracoli arriva lo schermo di KWallet per la main password e la scheda di rete si connette! Che averlo lanciato come superuser lo abbia sbloccato? Non so che dire, rimane un mistero..

Dopo circa 4 ore + 1 ora per la procedura d’aggiornamento il laptop e` di nuovo on line!

Ma ovviamente i problemi sono finiti, dopo l’aggiornamento compiz non parte piu`. La cosa strana e` che sembra completamente sparito fusion-icon! Provando a reinstallarlo dalla repository si vede chiaramente che qualcosa di parecchio brutto deve essere successo al data base di apt-get, visto che l’installazione fallisce con un errore su alcuni file di phyton che non esistono!

Inoltre X va di un lento che sembra una lumaca altro che un pinguino! E questo senza nemmeno compiz.. una piccola verifica e il tutto e` subito spiegato, col passaggio alla 9.04 il sistema non utilizza piu` i driver proprietari NVidia per la scheda grafica.  Ovviamente prima dell’aggiornamento stavo usando i driver proprietari con delle buone prestazioni e compiz perfettamente funzionante.

Qui mi sono fermato, l’installazione sul laptop e` un campo di prova, non ho grossi problemi a ripartire da zero e reinstallare una 9.04 pulita.. sperando di aver maggior fortuna!

Tirando le somme, costo dell'(tentato) aggiornamento del laptop: 6 ore per poi dover comunque reinstallare tutto; dopo questa prima esperienza il consiglio e`: evitate l’aggiornamento se non siete degli utenti esperti o se non potete permettervi di perdere un numero considerevole di ore!

(continua con l’aggiornamento sul desktop)

5 risposte a “Upgrade a Kubuntu 9.04: un incubo! (parte 1)”

Alex - Microsmeta ha scritto un commento il maggio 9, 2009

Andrea, secondo me è ancora una volta colpa di KDE 4!

Io ho installato Ubuntu 9.04 (Gnome) su 3 PC. Un P4 3.06 NVIDIA MX 440, un Notebook Athlon XP 2800+ ATI Radeon Mobile 9200, e un Athlon XP 200o +  NVIDIA MX 440. Tutto hardware vecchissimo. Ho sia eseguito avanzamenti di versione da Ubuntu Plus 2, che installazioni complete, su Virtualbox e con Wubi e mi funziona tutto: internet, LAN, wifi, Compiz (ma non su Virtualbox) e ti sto scrivendo dal PC potenzialmente peggiore dove Ubuntu 9.04 gira BENE.  Addirittura sul notebook 2008 ci faccio girare XP in una virtualboxcon un totale di 1,256 K disponibili. Ho provato varie volte a installare Kubuntu 4, 4.0x, 4.1, 4.2 e ho avuto sempre tantissimi problemi pure io.Ti consiglio di provare (anche) Ubuntu 9.04, magari anche solo da LIVE CD. Oltre alla frammentazione di 20o distribuzioni ci sono pure le fazioni KDE / Gnu  ed è difficile passare da una barricata all’altra,ma per quanto mi riguarda Ubuntu (pur con diversi problemi firtunatamente tutte risolti)  funziona egregiamente. Mi piacerebbe sentire l’opinione di Carlo TA, di Mapo, di The One Electronic , di SilviaKittys e di tutti i tuoi lettori / ascoltatori per avere quante più testimonianze possibili… Secondo me ne sai più te, ma se posso esserti utile (ho scritto un sacco di post al riguardo, sai dove trovarmi 😉 )

Il Nissardo ha scritto un commento il maggio 9, 2009

Caro Alex, leggo sempre con molto interesse tutti i tuoi articoli riguardanti le varie distribuzioni Canonical. Nella seconda parte di questo post (che spero di finire in un paio di giorni) vedrai che i problemi che ho avuto con il desktop sono decisamente piu` seri e purtroppo confermati anche su Ubuntu.
Quasi tutti i problemi che ho avuto sono legati all’aver aggiornato sistemi esistenti e fortemente personalizzati: il desktop non era mai stato reinstallato dalla 7.04, sempre aggiornato, ed ad ogni aggiornamento ho avuto grossi problemi (la migliore fu 7.04 -> 7.10). E non ti parlo di hardware vecchio o particolarmente ostico.
Una volta risolti i problemi tutte le macchine funzionano alla grande, quindi la mia non e` assolutamente una critica a linux.. sicuramente c’e` un problema in Canonical riguardo i cicli di QA. I problemi che ho avuto non possono essere tollerati in una distribuzione che si pone come obbiettivo “linux on every desktop”. Se quello che e` successo a me fosse successo ad un utente poco esperto di linux sarebbero stati dolori! Io me la sono cavata bene, anche nel caso del desktop alla fine ho perso soltanto tempo, mai dati o cose simili.. ma il tempo costa, se un’azienda avesse una 20ina di macchine e decidesse di aggiornarle con gli stessi problemi che ho avuto io, il costo in termini di tempo uomo sarebbe stato uguale (se non superiore) ad una licenza Microsoft.

Come ho letto in un blog pro-linux, se Microsoft avesse fatto uscire un aggiornamento cosi catastrofico come quello di Canonical per schede ATI (di questo principalmente parlero` nel prossimo post) se ne sarebbe parlato nei telegiornali di tutto il mondo. Per fortuna di Canonical non siamo ancora a questi livelli, gli utenti linux sono ancora degli “esperti” e se la sanno cavare bene. Ma prima di poter proporre Ubuntu/Kubuntu come alternativa a Windows per tutti ne deve scorrere d’acqua sotto i ponti.
Questo detto da uno che si e` installato la prima versione di linux usando 7 floppy 🙂

lapo ha scritto un commento il giugno 14, 2009

ragazzi io ammiro questo open source però mi sono rotto i xxxxxxx!!!
non è possibile ho aggiornato alla nove e non parte il driver video primario ati, quindi inutile il fixsever dal recover mode! ma è possibile ci sono sempre problemi uno non può stare a perdere giornate!!!!!

Il Nissardo ha scritto un commento il giugno 15, 2009

Come ti capisco!! Non ho ancora avuto tempo di scrivere la parte due di questo post, ma avrei parlato proprio del problema che hai avuto tu!!
Su una cosa non sono d´accordo.. non c´entra l´open source, ma Canonical, che é un´azienda bella e buona 😀

Alex - Microsmeta ha scritto un commento il giugno 15, 2009

Non vorrei girarvi il coltello nella piaga, ma a me Ubuntu 9.04 funziona benissimo su 3 pc 1 con ATI e 2 NVIDIA (pure vecchissimi) 😉

This blog is protected by dr Dave\'s Spam Karma 2: 147257 Spams eaten and counting...